Új WordPress verzió – és mit tegyél, ha összeomlik tőle az oldalad?

Share on facebook
Facebook
Share on google
Google+
Share on twitter
Twitter
Share on linkedin
LinkedIn

Májusra ígérték, június lett belőle, de végre itt van az új WordPress verzió, a 3.4-es. A szokásos módon készíts teljes mentést, mielőtt rákattintasz a megfelelő linkre, de az eddigi tapasztalatok szerint simán, gond nélkül megtörténik a frissítés, ahogy általában szokott. Ha mégsem így lenne, akkor jöhet az általam már sokszor leírt “általános eljárás fura hiba esetére”.

A WordPress verziófrissítés utáni oldalösszeomlások oka általában az, hogy egy olyan bővítményt használsz, amely összeakad az új változattal, és még nem frissítették a bővítményt. Ez általában pár nap alatt megoldódik, hiszen a sokak által használt bővítmények fejlesztői ilyen esetben kapnak párezer levelet, hogy legyenek már szívesek felnőni az új verzióhoz 🙂

Addig is jöhet a fent említett “általános eljárás fura hiba esetére”: azaz kapcsold ki az összes bővítményt és térj át ideiglenesen a TwentyTen sablonra. (Előtte nem árt bekapcsolni a karbantartás üzemmódot a Maintenance Mode bővítménnyel, hogy a weblapod látogatói ne értetlenkedjenek.) Ha a hiba így is fennáll, akkor valami más történt, nem a frissítés okozta a bajt – ekkor alighanem kénytelen leszel az adatbázisban turkálni…

Jobb esetben ilyenkor megjavul az oldal, tehát már csak azt kell kideríteni, melyik elem volt a ludas: kapcsolj vissza a saját sablonodra, majd egyenként kapcsold vissza a bővítményeket, és mindegyik után figyeld meg, hogy jó-e még az oldal, vagy megjelent a hiba. Amelyiknél elromlik az oldalad, azt a bővítményt (ritkább esetben a sablont) ne használd addig, amíg meg nem jön hozzá a javítás.

Nagy valószínűséggel azonban simán lefut a frissítés – ne lepődj meg, ez a verzió “kidobóst” játszik velünk, azaz a frissítés végeztével a bejelentkező oldalon találod magad:

Kidobóst játszik velünk a WordPress 3.4

A “csoda” valóban megtapasztalható, különösen, ha rengeteg bejegyzésed van, mert az új WP_Query jelentősen felgyorsította a bejegyzések lekérdezését. (Akinek pedig nálunk van tárhelye, az napokon belül csak kapkodni fogja a fejét az oldala betöltődését látva – ugyanis költözünk az új SSD szerverre! Erről hamarosan írok még…) Más eszközökkel is elértek gyorsulást a fejlesztők – ezekről az újabb szokás szerint a nyitó képernyőn olvashatsz, ha érdekelnek a technikai részletek.

Felhasználói szemmel a fejlécképek rugalmasabb kezelése és a Twitter folyamod (illetve az ahhoz érkezett válaszok) egyszerű beillesztése érdekes még, a saját kedvencem pedig a fényképek feliratozásának továbbfejlesztése: a képfeliratokat ezentúl formázhatjuk, sőt, akár linkeket is beleilleszthetünk.

Jó mulatást a csoda felfedezéséhez! 🙂

Oszd meg ha hasznos volt:

Share on facebook
Facebook
Share on google
Google+
Share on twitter
Twitter
Share on linkedin
LinkedIn
Ne maradj le semmiről, iratkozz fel hírlevelünkre!

Javasolt eszközök:

Banner250x250.png
Elementor Pro
Generatepress Logo White Asset
GeneratePress
Divi 4.0
Divihello
Prémium támogatás és ajándék Divi licence
Adatvedelem.png
ADATVÉDELEM minta
Aszf.png
Webshop ÁSZF minta

“Új WordPress verzió – és mit tegyél, ha összeomlik tőle az oldalad?” bejegyzéshez 9 hozzászólás

  1. Szia Moni!

    Azt szeretném kérdezni tőled, hogy vissza lehet térni régebbi wordpress verzióra? A fenti honlapomon 3.5 alpha verzió fut (a rendszer felajánlotta frissítésre), és most a képek felirata nem jól jelenik meg. pl itt: http://www.zahnbehandlunginungarn.at/kontakt/

    De más oldalakon viszont jók a képfeliratok: http://www.zahnbehandlunginungarn.at/zahnbehandlungen/prothesen/

    A másik wp-s honlapomon 3.4-es verzió fut, ott minden tökéletesen működik. Ebből gyanítom, hogy a más verzióból ered a gond.

    Nem értem, hogy a zahnbehandlunginungarn.at oldalon az egyik oldalon hogyhogy jól jelennek meg a kép aláírások, míg a másik esetében nem.

    Erre van valamilyen ötleted? Szerinted hogyan tudom visszarakni a wp 3.4-es verzióját?

    Köszönöm előre is
    Ildikó

    • Az alpha verziókat nem szabad éles honlapon használni! Az még nincs kész.

      FTP-vel töröld le a gyökérkönyvtárban lévő fájlokat, kivéve a wp-config.php és a .htaccess fájlokat, valamint a wp-admin és a wp-includes könyvtárakat. A wp-content mappát ne bántsd! Helyettük másold fel a 3.4-es telepítőcsomag megfelelő fájljait. (Megtalálod itt: http://hu.wordpress.org/releases/#older)

      A wp-contenten belül egyesével másold át az index.php fájlokat meg a languages mappát. (Azaz írd felül a 3.4-es fájljaival.) Ezek egyébként valószínáleg nem változtak, de biztos, ami biztos.

  2. Szia Moni!

    Köszi a gyors segítséget. Visszatettem a 3.4-es wordpresst. 🙂
    Mondjuk a képek felirata még most sem jó, lehet, hogy újra fel kell töltenem majd a képeket. Vagy addig ideiglenesen leszedem a feliratot. 😉

    Köszi és szép estét neked,
    Ildikó

  3. Szia Móni!

    Én azt szeretném kérdezni van-e arra lehetőség, hogy a nyitóoldalon egy kategória bejegyzései legyenek? (Több kategória van az oldalon) A 3.4 feldob olyan opciót, hogy a legfrissebb bejegyzések jelenjenek meg nyitó oldalon, de nekem csak egy kategória bejegyzései kellenének a nyitó oldalra.
    Szuper az oldal!
    Üdv,
    Péter

    • Köszi 🙂

      Ez sablonfüggő. Van olyan sablon, amelyik tudja ezt. Alapesetben az összes kategóriából teszi ki a bejegyzéseket időrendben.

      Azon gondolkoztam, hogy hogyan lehet ezt megbuherálni a saját menü használatával: beteszed a menübe azt a kategóriát menüpontnak, amelyiknek a bejegyzéseit meg akarod jeleníteni a főoldalon, és elnevezed “Nyitólap”-nak. A Beállítások -> Olvasás menüpontban viszont át kellene állítani, de az nem jó így… Egyszerűbb lenne, ha lenne tényleg egy nyitólap, valamilyen bemutatkozó szöveggel, és a kategóriát pedig berakod a menübe, ahogy az előbb írtam.

      Vagy valami ilyesmi… 🙂

  4. Nagy bajban vagyok. Frissítés után csak “Szerverhiba” látszik a weboldal helyett és még adminom sincs. Sajnos, nincs friss backup-om. Legrosszabb esetben vissza tudok állítani egy régebbi backup-ot, de remélem, van egy jobb megoldás, amitől nem veszítem el az utóbbi hónapok munkáját. A sablont az Artisteerben csináltam, de már bánom, inkább egy kész sablont töltöttem volna le. Ezt meg is teszem, amint sikerül visszaállítani a honlapot. Hol találom meg az utolsó előtti wp-verziót? Gondolom, azt kell visszaállítani.

    • Ne ezzel kezdd. Inkább menj fel FTP-vel a tárhelyedre, mentsd le az összes plugint és a sablont, majd ezeket töröld le. Ha így megjavul az oldalad, akkor egyesével tegyél mindent vissza: először a sablont, azután a bővítményeket, de egyesével, és kapcsold is be mindig az újonnan feltettet (a beállításaik nem fognak elveszni, azokat az adatbázis tárolja).

      Amelyiknél elromlik megint az oldalad, az a bővítmény nem kompatibilis az új WP-vel, és az okozta az összeomlást. Töröld le és használj helyette másikat vagy várd meg a frissítését.

      Az is simán lehetséges, hogy ha ezt végigcsinálod, egyik bővítmény sem okoz hibát, és újra működni fog minden. Jártam már így egy ügyfelemnél, ezért szoktam javasolni, hogy a WP-motor frissítése előtt kapcsolj ki minden bővítményt ideiglenesen.

      A régebbi változatú WP visszamásolása viszont azért nem segít, mert az adatbázisba már belekutyul a frissítés. Így pusztán a korábbi motor-fájlok visszamásolása nem elég.

      Sok sikert és szólj, ha nem boldogulsz!

  5. Kedves Szerkesztő!
    Olyan probléma lenne, hogy ha frissítem az WP-t a 3.7-es verzióra, a feltelepített összes téma /sablon közül , maga a sablon beállításainál egy fehér üres rész van csak. a Régebbi verzióval, testre tudom szabni a sablont. Tudna esetleg ebben segíteni,h ogy ez miért van?..:(
    Válaszát megköszönöm!

    Szívélyes üdvözlettel, Imre

    • Kedves Imre!
      Mivel többtízezer bővítmény és sablon létezik, így sajnos konkrét választ nem tudok adni, csak általánosat – azt, amit fentebb is leírtam. Valamelyik bővítmény vagy sablon összeakad egymással vagy a WP legújabb verziójával. Ugyanazt javaslom, mint amit egy hozzászólással feljebb Ivánnak írtam.
      Ha semmi nem segít, akkor sajnos könnyen lehetséges, hogy a sablon nem támogatja a legújabb verzió módosításait. A legjobb ilyenkor, amit tehet, hogy ír a sablon fejlesztőjének. Minél többen szólnak neki, annál hamarabb elkészíti a javítást. Ilyen esetben mindig le kell írni a pontos hibát, és azt, hogy milyen verziójú a WP, a sablon, és mely bővítmények vannak még a rendszerben.
      Remélem, sikerül megoldani a problémát. A végső megoldás a sablon lecserélésre, de ez azért fájdalmas szokott lenni. (Bár néha nem is árt egy kis arculatfrissítés…) Természetesen a tartalmakból ilyenkor semmi nem vész el, hiszen a tartalmakat az adatbázis őrzi, de a widgeteket azért mindenképpen érdemes előtte egy Jegyzettömbben összeírni, a szövegeseket kimásolni, hogy ne vesszenek el, mert azok sokszor a sablon beállításaival együtt vannak tárolva (ha nem szabványos oldalsávja van a sablonnak).

Szólj hozzá!

Ez a weboldal az Akismet szolgáltatását használja a spam kiszűrésére. Tudjunk meg többet arról, hogyan dolgozzák fel a hozzászólásunk adatait..